Home
Up

 

Choosing the correct software.

There are many different types of mobile phones that are capable of running
Java application software such as AviatorCalc and Pilot Calculator. These have two specifications namely MIDP 2.0 CLDC 1.1 for newer mobile phones and MIDP 1.0 CLDC 1.0 for older or more limited mobile phones. AviatorCalc will not run in the older phones. To find out what type of of phone yours is, first install the Crosswind Demonstration Program and run the System Information menu item

  AviatorCalc version 2.0
 
Pilot Calculator version 1.1
 
 
  • Runs on MIDP 2.0 CLDC 1.1 mobile phones only. (Newer mobile phones)
     
  • Eight Aircraft Database, Thirty Airports database, Flight Planning, Navigation, Weight & Balance and Weather services.
     
  • Programs are fully integrated with each other and exchange information.

 

  • Runs on both MIDP 1.0 CLDC 1.0 and MIDP 2.0 CLDC 1.1 mobile phones. (Older or more limited mobile phones)
     
  • Six Aircraft Database, Flight Planning, Navigation, Weight & Balance and Weather services.
     
  • Programs are standalone


 

       
  Run the Cross wind demonstration
 
 
 
 

Load the free Cross wind  Demonstration software. Select System Information from the menu.

 

 

 

If you see that your mobile device is a  MIDP 2.0 CLDC 1.1  device then you will be able to run the AviatorCalc software.  If not it may be that you will have to use Pilot Calculator or of course update your mobile phone.

 


Site updated 30 March, 2008  Copyright 2004 Bob Rathbone. All rights reserved